PassMark Logo
Home » Forum


No announcement yet.

[ERROR] Error: Failed to load C:\Program Files\Zoom Search Engine 8.0\7z64.dll

  • Filter
  • Time
  • Show
Clear All
new posts

  • [ERROR] Error: Failed to load C:\Program Files\Zoom Search Engine 8.0\7z64.dll

    According to the release notes, this bug was fixed in build 1014. However, I still get this error in both builds 1015 and 1016 running under Windows 10 Pro x64 20H2.

    P.S. The file 7z64.dll (v15.6.0.0) is, in fact, present at the location C:\Program Files\Zoom Search Engine 8.0\
    Last edited by imcz; 06-27-2021, 10:28 AM.

  • #2
    Does it happen all the time, which types are you trying to index that triggers it?
    Send us the whole log file if you want.


    • #3
      The error occurs all the time, before ZSE attempts to index anything. A log file is attached.
      Attached Files


      • #4
        The error in your indexlog is different to the one in the changelog. Note the folder location is different,

        13:36:09 - [ERROR] Error: Failed to load C:\Program Files\Zoom Search Engine 8.0\7z64.dll
        Can you please confirm if this file is missing from the folder specified.

        I have just confirmed build 1016 correctly installs this file at this location.

        Please confirm your installation procedure -- are you using the installer (or copying the files from another installation), or you're installing in a 32-bit environment and then running from a 64-bit environment.
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine


        • #5
          The file is *not* missing from the specified location:
          Click image for larger version

Name:	MissingDLL.png
Views:	63
Size:	58.4 KB
ID:	38116
          AFAIK, I am using the standard, 64-bit installer. Otherwise it would have installed ZSE under Program Files (x86). Unfortunately, the installation file doesn't contain version info:
          Click image for larger version

Name:	InstallFile2.png
Views:	59
Size:	17.4 KB
ID:	38118
          The download page doesn't offer me different versions for 32- and 64-bits:
          Click image for larger version

Name:	DownloadPage.png
Views:	67
Size:	92.1 KB
ID:	38120
          This page now identifies the current version as 1015, but the install file I get from it is identical to the one I got earlier as 1016.
          Attached Files


          • #6
            The build number on the download page was out of date and has since been rectified. This would not be the cause of the issue.

            You are using build 1016, as can be seen in the indexlog file.

            If the file plainly exists in the folder according to Explorer, then there's a more unusual problem at hand.

            Only thing that comes to mind is if you have any anti-virus program running which is silently blocking access to the file -- incorrectly so as it is not a virus or any malware file. You might want to check with your AV software if there is a log of what files it is blocking and if it can be temporarily disabled for testing purposes.

            You can also revert to a previous build to test if this behaves differently.

            I'm unable to reproduce any problem like this, having tried it on several different test machines.

            Wrensoft Web Software
            Sydney, Australia
            Zoom Search Engine


            • #7
              Thanks for responding. I would have responded sooner, but once again I received no e-mail notification of your post. My only AV is Windows Defender, which shows no record of blocking this (or any other) DLL. I uninstalled build 1016 and installed build 1014, but the error still occurs. Furthermore, the logfile still identifies the build as 1016. Is there some manual cleanup required to downgrade the installation?

              Could the DLL error be due ta a failure to register the DLL? I am starting the installation from a non-privileged account and then granting installation privileges from an admin account at the UAC prompt. Do I need to use "Run as administrator" to start the installation.

              BTW, the logfile also incorrectly identifies my Windows version as 8. I am running Windows 10 Pro x64 20H2.

              P.S. In the installation directory (c:\Program Files\Zoom Search Engine 8.0\, I find the following file properties:
              • ZoomEngine64.exe v8.0.1004.0
              • ZoomIndexer.exe v7.1.1022.0
              Where is the version info in the log coming from?
              I will try deleting the installation directory after deinstallation and before reinstallation.

              P.P.S I have now:
              1. Uninstalled ZSE
              2. Deleted the directory c:\Program Files\Zoom Search Engine 8.0\
              3. Installed ZSE 8.0.1012 using "Run as administrator"
              • The versions of the EXE files in c:\Program Files\Zoom Search Engine 8.0\ are still as above.
              • However, Help - About identifies ZSE as 8.0 (build 1012).
              • The DLL load error no longer occurs.
              • The logfile now says Version 8-0 (Build 1012).
              • The logfile still says "on Windows 8".
              Last edited by imcz; 07-28-2021, 05:36 PM.