PassMark Logo
Home » Forum


No announcement yet.

PDF is indexed but never appears in search results

  • Filter
  • Time
  • Show
Clear All
new posts

  • PDF is indexed but never appears in search results

    I have a PDF that is being indexed but never appears in any search results by my ZOOM installation. I'm using version 6. The PDF is not password protected. I'm able to open it up and select text and whatnot. There are no errors or warnings during indexing either. I can supply the PDF if required.

    I've read through the FAQ but I can't seem to find a solution to my problem. Any help would appreciated.


  • #2
    Yes, E-mail us the PDF or post a link to it.


    • #3
      Here's a link to the PDF. 0Plan.pdf

      If I search for the word "Rural" this PDF never appears in the results.



      • #4
        I tested indexing this PDF and could not replicate the problem. It was successfully indexed and I could search for the word "rural".

        Things to check:
        (1) That this file was actually indexed. Please check the "Log" tab or save the index log to file and see if there is actually a message indicating this file was indexed. Send us the log file if you are not sure.
        (2) Is the PDF file being served via a PHP script or similar? (e.g. a URL like "download.php?id=123") There may be a problem with the way the PHP script is serving the file.
        (3) Make sure the index you most recently created (and verified the log for) was actually uploaded to the server where you are running the search script. A common mistake is to upload the files to a different folder and ending up running the searches with an older set of index files.

        Email us the .zcfg configuration file if the above don't help, and we'll take a look at your settings.
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine


        • #5
          Thanks. I've tried all those things. Here are the log and config files. I've removed the FTPINFO_START bits from the config file.
          1. Checked the log file and found these items at the following lines:

            Queued at line: 5832
            URL at line: 12345
            Downloaded at line: 12346
            Ready buffer at line: 12365
            Processing at line 12366
            Indexing at line: 12369

          2. The PDF file is not being served via a script.

          3. I've also verified the index is being uploaded to the correct folder and that new pages are being included in the search results.

          Thanks for taking a look.


          • #6
            We had a look at the files. Couldn't see anything that would cause a problem. We also tried directly indexing the URL specified in your log file (as the start spider URL), using your .zcfg file with all the same settings, and it succeeded again.

            We then went to your website. In the search box we entered in "rural official community plan" and selected the PDF file type in the drop down box, and we can see the result is #3 in the list.

            Let us know if we missed something, or if it's since been fixed?
            Wrensoft Web Software
            Sydney, Australia
            Zoom Search Engine


            • #7
              Wow, I'm a little surprised. I looked all over that result but obviously it was right there.

              Thanks for your time. Looks like there's no problem now.