PassMark Logo
Home » Forum

Announcement

Collapse
No announcement yet.

Erro with V8 - deprecated strcasecmp()

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Erro with V8 - deprecated strcasecmp()

    We are published Help & Manual to PHP for the first time, using Zoom Indexer 8. We get this error message:Click image for larger version

Name:	image.png
Views:	107
Size:	7.2 KB
ID:	38284

    Do you know what this error message is about? Thanks so much​

  • #2
    The search script should still work, though if you open the search.php file and go to line 2080:
    Code:
    if (strcasecmp($div_res_urls[$div_url_i], $domainBuffer) == 0)
    And change it to:
    Code:
    if (strcasecmp($div_res_urls[$div_url_i], $domainBuffer ?? "") == 0)

    This should fix the warning.

    Comment


    • #3
      Thanks, Simon. I made the change on line 2808. Then I published. But I still got the error message. When I checked the files, it had reverted the serach.php file to the old one (I can see the old date), and the change was missing. Do you have any thoughts on what might be happening? Thanks so much.

      Comment


      • #4
        Are you using Zoom to upload the files at the end on indexing? If so, search.php is probably being replaced with the default script. Go to FTP > FTP Options and check 'Do not upload search template'

        Comment


        • #5
          You'll probably need to specify a custom search script in the advanced settings.

          You might or might not need to change the template setting as above.

          Click image for larger version

Name:	Custom-search-script.png
Views:	125
Size:	297.1 KB
ID:	38289

          Comment


          • #6
            Thank you both for your quick responses. I made the two changes above. Now the new search.php file appears to be used, as it is in the file list after I publish. I verified that it has the updated code.However, I still have the same error message as before. I wonder if permissions might have something to do with it. We also get another error message. Click image for larger version

Name:	image.png
Views:	90
Size:	20.1 KB
ID:	38291

            Comment


            • #7
              Is it exactly the same error, with the same line number?

              For the 2nd issues, with the log file, either the directory doesn't exist, or the User running the search script doesn't have permission to create and write a file in that folder.

              See also this FAQ
              https://www.zoomsearchengine.com/zoo...t/logging.html

              Comment


              • #8
                Yes, I am still seeing the error for line 2808. But it now says parameter #1. What would your suggestion be for that error? Thanks so much for your help.

                Click image for larger version

Name:	image.png
Views:	78
Size:	7.0 KB
ID:	38294

                Comment


                • #9
                  FYI, There is now a new build, 8.0.1020, with changes to the search.php script which should address the deprecated warnings:
                  https://www.zoomsearchengine.com/zoom/download.html

                  So you won't need to use the custom script path setting mentioned above.

                  Comment


                  • #10
                    Thank you for that suggestion. i was able to download the new build. I am now receiving an error message as follows:

                    Click image for larger version

Name:	image.png
Views:	62
Size:	5.3 KB
ID:	38297

                    Comment


                    • #11

                      Might you have edited our PHP script and broken it?
                      I say this because that line of code, 1583, looks OK in our script and has worked fine for more than a decade.

                      Comment


                      • #12
                        I have downloaded the new Zoom Indexer version. I had formerly used a new search file that Tim Green provided to me. I have deleted that file. Now I have republished and I see the two error messages that I had before. The first error message is multiple - it seems to be displaying one for each search result.

                        Click image for larger version

Name:	image.png
Views:	50
Size:	6.9 KB
ID:	38300

                        Click image for larger version

Name:	image.png
Views:	46
Size:	13.4 KB
ID:	38301

                        Comment


                        • #13
                          For log file error, see our comment above.

                          For deprecated message, we suspect you are still using a "custom script source path". That is to say, you are using a old customised script and not the default one from the current build.

                          If this is not the case can we get a copy of the search.php file you have on your server.

                          Comment


                          • #14
                            We have been working with our IT department to try to resolve the permissions error with the log file. I have downloaded the latest Zoom Indexer and we are still seeing the permissions error. The help page on your website appears to be out of date: Zoom Search Engine - Support - Logging​ They asked me to reach out to see if you had any updated instructions they can follow.

                            Thank you for your help.

                            Comment


                            • #15
                              Most of that support page just talks about Linux file paths and chmod file permissions. None of this stuff has changed in the last 30 years and I suspect it will be the same for the next 30 as well.

                              96% of web servers are running Linux.

                              But maybe are you in the 4% running Windows and IIS? And it is true that Windows and IIS permission setting is a mess. Did you experiment with different paths. Starting with something simple. e.g. c:\logs\

                              Comment

                              Working...
                              X