PassMark Logo
Home » Forum


No announcement yet.

A bit of a panic

  • Filter
  • Time
  • Show
Clear All
new posts

  • A bit of a panic

    Sorry for the addition of a plea for help . . . BUT

    I have been using the same configuration files (version 6) for a while so was surprised, confused and frustrated when I tried to update a clients site .
    I have used categories each time there are updates to the pdf's on his site - so full of confidence I rescanned after updating the site but no categories show up - as in no categories.zdat or whatever the file is called - the categories are turned on in the checkbox when scanning, the categories are set to locations that exist but no categories come through - if I leave the selection to "all" I find the files as usual, but If I narrow the search to only one (any one) no can find.

    Any suggestions would be greatly appreciated - it is supposed to be up and running again on Monday!

    Thanks in advance

  • #2
    The most likely explanations are one of the following,
    1) You used the wrong configuration file
    2) The patterns used for the categories don't match any of the URLs found on the site
    3) Only part of the site was indexed, and not the part that was meant to be categorised.

    Also there is no categories.zdat file used with version 6 of Zoom. So this is normal.

    What are the patterns you are using? And what URLs are you expecting them to match?
    Are you using offline mode or spider mode?


    • #3
      This is what is returned after a spider mode


      Here is the site

      both the french and english side

      as I look at past results it lists
      which is not listed in the new scan of documents (as above) so I fear that if you search with all selected all will be fine - if you look for a part JUST in fittings it won't show up

      I thank you once again for your time - stress sucks!


      • #4
        Again, what are the patterns you are using? And what URLs are you expecting them to match? E-Mail us your Zoom configuration file if you want.

        The zoom_cats.zdat file is no longer used with version 6 of Zoom. So this is normal. Category information has been combined into the other files.


        • #5
          Thank you once again

          <Blush>Odd how important an underscore in the name can become - as in _pdf which is where the files were as opposed to pdf where I told it to search! </blush>

          If I may ask another question? I believe it is an IE problem, but have not found the resolution in my messing about with the search.css .zoom_searchform

          Try this url in IE then in Firefox or Safari

          Again your suggestions would be greatly appreciated

          Thanks for your previous help, thanks for your patience



          • #6
            There's over 20 errors in your search_template.html file, which made it a bit of a task for us to try and determine the problem. Use a site like (EDIT: wrong link given in original post, now fixed) to check if your page validates and if the HTML code is correct or not.

            Pages that do not validate are very likely to display differently on different browsers (and even those that do can display differently depending on browser quirks).

            The easiest way to solve your problem is by moving the ZOOMSEARCH tag on your template file so that it is not within a paragraph.

            This is what you currently have in search_template.html:

               <!-- This is where the search form and results will appear -->
            Remove the <p> tag before the ZOOMSEARCH line and it should appear as you want.

            More detail: this normally isn't a problem, and it's not because you can't put the ZOOMSEARCH tag within a <p> tag. The real problem is that the rest of your styles (scattered over the page and in the other CSS file you have) defines conflicting behaviour, and also combined with the DOCTYPE specified (XHTML 1.0 Transitional) which makes IE behave a certain way with unmarked lists that is different to other browsers.

            So you could avoid it also by changing the DOCTYPE of the page, but that might be more difficult for you to tackle if you are not very experienced or familiar with HTML standards and the various browser quirks and behaviour changes this will invoke. So I suggested the easier workaround for you.
            Last edited by Ray; Jan-10-2011, 05:20 AM. Reason: Typo'ed the W3 Validator URL
            Wrensoft Web Software
            Sydney, Australia
            Zoom Search Engine


            • #7
              Thank you!

              Although I can't think of anyone who wants to see
              "There's over 20 errors in your search_template.html file, which made it a bit of a task for us to try and determine the problem."

              The thought - " WTF - don't give up your day job" may have been implied and not without reason.

              Damn! my day job is retired and No! I won't give it up.

              Thank you for the help - yes, the removal of the <p> tag resolved the main problem ( though I have to say I have no idea why)- I will now try to resolve the 20 something errors - by the way the link results in something less than you wanted. But if you want to buy the domain I think they are interested.

              I am using, as you likely know, Dreamweaver CS4 where the default seems to be XHTML1.0 transitional a setting I did not change - a validation check in Dreamweaver showed 2 errors - so I have to spend some more time.

              My code is obviously not "clean", - I can work on that, the fact that it "works" tomorrow morning is more important. I have enjoyed the construction of the site - we may disagree on the success of the site itself, but thank you for both the comments and for the software, the ability for my friend/client to have the ability to search the large number of pdf catalogs may well be worth my stumbling. I will continue with, perhaps I will get my errors down a tad

              Thanks for your time



              • #8
                No slight was intended, we all have to start somewhere.

                It's not uncommon at all to have validation errors, but it's worth noting what effect this will have. What I meant to suggest is that there are many influencing factors on how a browser may render a page, and there may well be other quirks that will show up later given the underlying problems - and I wanted to stress that it's not caused by Zoom specifically should they show up later.

                And you're right, the URL for the W3 validator was wrong, I've corrected it in my above post now.
                Wrensoft Web Software
                Sydney, Australia
                Zoom Search Engine


                • #9

                  Thank you Ray!
                  There are not many resources I can access, no one I know on my island Gabriola BC ( I can call, text or email, or have a chat with - that can solve a problem - I spent about 4-5 hour messing around trying to solve my issues - you solved it from your "island' in an incredible short time - Thank you! It would be so nice to be able to call "Bob" and discuss the problem but . . . .Bob apparently doesn't live here - so I pester you guys - and with great results

                  I have had I think 3 or 4 questions since starting to use zoomsearch - they have all been resolved far faster than expected I really appreciate the response

                  I wasn't suggesting Zoom was the problem - somehow I knew it was my implementation. I started this "stuff" before there was a "Dreamweaver",- damned if I can remember the apple program that did html - I believe Photoshop was at 1.0 and Netscape was in Beta - by now, at 63, I should have some sense of what is happening in the code I extricate from Dreamweaver . . . . perhaps not

                  Thanks for your help and patience