PassMark Logo
Home » Forum


No announcement yet.

Search engine problem - Subscript out of range

  • Filter
  • Time
  • Show
Clear All
new posts

  • Search engine problem - Subscript out of range

    I have a copy of one of my key products on the back of the company website, which is hosted by a large UK hosting company, which I use to let prospective customers try the product out before contracting to use it. Searching works OK on my own computer (using localhost on IIS) and in each customers site that's already using it. It used to work on my website, but hasn't for a while. My hosting company, on being asked to fix the issue, say the search is using too much memory. I tried removing all the pdfs on my site from the search index, to reduce the size of the zoom page and word files, just to see what happened and copied the new files over. It worked the first time I tried it, but subsequently doesn't, giving the following error the next time:

    Microsoft VBScript runtime error '800a0009'

    Subscript out of range: '42492'

    /pvhoct2010938rurywhale8dh3mdiejr2094/S10005.asp, line 2056

    The next search gave the same error but with Subscript out of range: '9033'

    Line 2056 is the equivalent of line 1915 in search.asp:

    if (boost(ipage) <> 0) then

    I would be grateful for any advice as to why the search is failing, or confirmation that my hosting company is indeed correct, that there isn't enough memory, and some advice as to what I should do.

    Many thanks

  • #2
    A subscript out of range error sounds like it's most likely either:

    (a) You have a corrupt set of index files due to manually copying or uploading the files to your server and omitting some files on overwrite (so you ended up with a mix of files from different index sessions).

    (b) You have a corrupt set of index files due to uploading the files with a third-party FTP program which mistakenly uploaded the ZDAT files in ASCII/Text mode when it should be uploaded in BINARY mode.

    (c) You have modified the ASP files (search.asp or settings.asp) in some way and broken script functionality. Please inform us if the files have been modified in any way at all.

    For (a) and (b) you should be able to fix this by simply re-indexing and re-uploading the files correctly, making sure to upload all the files listed at the end of indexing. Or use Zoom to upload to be sure.

    If none of the above fixes the problem, please check the version and build number of Zoom you are using, on the off chance that you are using an older build which may have had a bug that has since been fixed.
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine


    • #3
      Thanks Ray
      c. not possible due to it working locally OK, so I suspect the copying over and will load up another set of new files.


      • #4
        Hi Ray, it was the copying over. The file zoom_pagetext.zdat is 23MB and often failed to copy completely. I've taken to FTPing each Zoom file separately to make sure it copies over completely before I do another.


        • #5
          That seems to have fixed it. Thanks for your help! Your customer service is exceptional!