PassMark Logo
Home » Forum


No announcement yet.

Permission denied: Unable to connect to cgi daemon after multiple tries

  • Filter
  • Time
  • Show
Clear All
new posts

  • Permission denied: Unable to connect to cgi daemon after multiple tries

    We have been a Zoom Indexer customer for years and have been successfully running search.cgi on a Linux web server. Last week, we installed a new Linux web server with an upgraded version of Apache.

    - Redhat Linux 7.4
    - IBM HTTP Server

    We are using our existing bat files to move the following files from our zoom indexer server to the new Linux webserver.
    We are receiving the following error below.
    Error.log (See attached file)
    [Thu Jun 21 00:43:31.382519 2018] [cgid:error] [pid 26897:tid 140095082698496] (13)Permission denied: [client] AH01257: unable to connect to cgi daemon after multiple tries: /u/HTTPServer/cgi-bin/index/search.cgi

    Access.log (See attached file) - - [21/Jun/2018:00:43:31 -0400] "GET /cgi-bin/index/search.cgi?zoom_query=general%20ledger&zoom_page=1 &zoom_per_page=10&zoom_and=0 HTTP/1.1" 503 787 892

    Currently we have the permissions set on the files to 777 but we still get the error above. Any assistance would be greatly appreciated!

  • #2
    Your post mentioned attached files. But there are no attached files.

    The error says permission denied. So maybe it is a permissions problem? Did you make the .cgi file executable in Linux? Also what hardware is this running on? Our .cgi is x86 only. So if this is on some obscure PowerPC or ARM CPU it isn't going to work.

    We've never done any testing with IBM HTTP Server. The only reason that you'd use this IBM package over the free Apache product is that it comes with IBM's support. Might be time to use it.


    • #3
      I can post the logs if that would be helpful. With our prior Linux server, it worked with the search.cgi - we did not make it an executable. We thought making all of the files 777 would eliminate the permissions error but that is not the case. We aren't sure what we are missing from a permissions perspective.


      • #4
        This question was also sent in as an email support ticket, so we are attending to it there.
        Wrensoft Web Software
        Sydney, Australia
        Zoom Search Engine